Keinginan adalah kunci motivasi, tapi tekad dan komitmen itu pengejaran tanpa henti untuk sebuah tujuan yaitu komitmen menuju keunggulan yang akan memungkinkan Anda untuk mencapai keberhasilan yang Anda cari.

Selasa, 28 Agustus 2012

LOAD BALANCING


TUGAS APLIKASI JARINGAN KOMPUTER I
MENGIMPLEMENTASIKAN LOAD BALANCING
UNTUK MENGOPTIMALKAN JARINGAN




Esti Yuliana                  (SIR200938)

Dosen Pengampu  :  Adnan Purwanto, S. Kom


SEKOLAH TINGGI MANAJEMEN INFORMATIKA DAN KOMPUTER
(STMIK) WIDYA UTAMA PURWOKERTO
2012

ABSTRAK

Seiring dengan meningkatnya kebutuhan akan penggunaan sumber daya yang ada didalam jaringan komputer telah mengakibatkan timbulnya pengembangan teknologi jaringan itu sendiri. Ketersediaan akan sumber daya yang berbanding terbalik dengan tingkat kebutuhan saat ini telah menuntut teknologi jaringan untuk mengambangkan suatu teknik baru yang dapat mengatasi masalah tersebut. Load balancing merupakan salah satu teknik routing yang dapat memanfaatkan beberapa sumber daya untuk dapat digunakan secara bersamaan. Ketika banyak permintaan dari pemakai  maka server tersebut akan terbebani karena harus melakukan proses pelayanan terhadap permintaan pemakai. Solusi yang cukup bermanfat adalah dengan membagi-bagi beban yang datang ke beberapa server, Jadi tidak berpusat ke salah satu perangkat jaringan saja. Teknologi itulah yang disebut Teknologi Load Balancing. Dengan Teknologi Load`Balancing maka dapat diperoleh keuntungan seperti menjamin reabilitas servis, availabilitas dan skalabilitas suatu jaringan. Akan tetapi, ada berbagai metode pula yang dapat digunakan, diantaranya metode NTH dan PCC load balancing. Kajian ini bertujuan untuk membandingkan metode mana yang lebih baik, sehingga sumber daya yang ada terpakai secara optimal.



BAB I


A.    Pendahuluan

Dalam sistem paralel dan mendistribusikan lebih dari satu prosesor memproses program paralel. Jumlah waktu proses yang diperlukan untuk melaksanakan semua proses ditugaskan untuk prosesor disebut beban kerja prosesor. Sebuah sistem komputer didistribusikan dengan puluhan atau ratusan komputer yang terhubung dengan jaringan kecepatan tinggi memiliki banyak keuntungan dibandingkan sistem yang memiliki komputer standalone yang sama. Sistem terdistribusi menyediakan berbagi sumber daya sebagai salah satu keuntungan utama, yang menyediakan kinerja yang lebih baik dan keandalan daripada sistem tradisional lain dalam kondisi yang sama.

Lokal penjadwalan yang dilakukan oleh sistem operasi terdiri dari distribusi proses untuk irisan waktu prosesor. Load balancing adalah klasifikasi lebih lanjut penjadwalan dinamis. Beban perjuangan berbagi untuk menghindari negara unshared di prosesor yang tetap diam sementara tugas bersaing untuk layanan di beberapa prosesor lain. Load balancing juga melakukan hal yang sama namun ia pergi satu langkah di depan untuk berbagi beban dengan mencoba untuk menyamakan beban pada semua prosesor.

B.     Latar Belakang

Sering terjadi permasalahan pada jaringan komputer antara lain data yang dikirimkan lambat, rusak dan bahkan tidak sampai ke tujuan. Komunikasi sering mengalami time-out, hingga masalah keamanan. Selain itu terdapat 2 modem yang tidak terpakai secara optimal, sehingga akses internet tidak maksimal.Oleh sebab itu, jaringan komputer memerlukan sebuah router, yaitu alat yang berfungsi sebagai pengatur jalur lalu-lintas data sehingga tepat pada sasarannya.Router mampu menjawab tantangan daripada permasalahan jaringan komputer itu sendiri. Dengan berbagai fasilitas yang dimiliki router, maka komunikasi pada jaringan komputer dapat berjalan dengan baik.
Namun, harga router tidak murah, hal ini sesuai dengan kinerja yang dihasilkan dari router itu sendiri. Hingga ditemukannya sebuah solusi yaitu Sistem Operasi yang dikhususkan untuk networking, yaitu MikroTik Router OS yang terbukti murah dan handal dalam melakukan kerjanya sebagai router. Banyak digunakan di ISP sebagai Limit bandwidth, router pada warnet, Gateway pada Kantor, hingga pada kafe sebagai hotspot.
Penanganan dan perawatan sebuah jaringan komputer dilingkungan suatu organisasi/instansi sering menghadapi masalah. Masalah-masalah tersebut biasanya terletak pada masalah keamanan, masalah keandalan, ketersediaan dan skalabilitas jaringan komputer. Untuk merealisasikan penggunaan jaringan komputer yang dapat mengimplementasikan seluruh aplikasi berbasis web perlu adanya penyesuaian infrastruktur sesuai kebutuhan. Implementasi seluruh aplikasi berbasis web diperkirakan membutuhkan sebuah konfigurasi server yang handal dan juga dapat mengantisipasi kebutuhan masa depan. Implementasi sistem jaringan komputer yang akan dilaksanakan di lingkungan suatu organisasi akan menjadi suatu prototipe sistem jaringan komputer untuk organisasi lainnya.

Dengan jumlah pengguna jaringan komputer berjumlah lebih dari 1000 orang yang akan menggunakan fasiltas aplikasi layanan berbasis web maka dibutuhkan sebuah konfigurasi server yang handal. Selain sisi konfigurasi hardware yang menjadi pertimbangan agar server nanti andal maka terdapat layanan-layanan yang ada pada server harus bisa mengantisipasi pengaksesan aplikasi berbasis web tersebut secara simultan dan mempunyai frekuensi yang sanga tinggi. Untuk itu akan diimplementasikan layanan Load Balancing yang dapat meningkatkan keandalan aplikasi berbasis web dan sistem jaringan komputer. Sebelum hal tersebut dilakukan maka infrastruktur jaringan komputer untuk lingkungan suatu organisasi/instansi harus disesuaikan dengan kebutuhan. Untuk menyelesaikan masalah ini maka dilakukannya konfigurasi Load Balancing Pada Sistem Jaringan Komputer.  

C.    Rumusan Masalah

Dalam makalah ini, penulis membatasi masalah yang akan dibahas pada materi kuliah Aplikasi Jaringan Komputer I. Pembahasan lebih dikhususkan pada Mengimplementasikan load balancing untuk mengoptimalkan jaringan

D.    Tujuan Penulisan

Makalah ini dibuat untuk memenuhi tugas ujian mid semester mata kuliah Aplikasi Jaringan I di STMIK Widya Utama Purwokerto.

E.     Manfaat

a.       Mahasiswa dapat menambah pengetahuannya tentang mengimplementasikan load balancing untuk mengoptimalkan jaringan.
b.      Mahasiswa dapat menambah pengetahuan yang lebih tentang teknik untuk mendistribusikan beban trafik pada dua atau lebih jalur koneksi secara seimbang, agar trafik dapat berjalan optimal, memaksimalkan throughput, memperkecil waktu tanggap dan menghindari overload pada salah satu jalur koneksi.
c.       Makalah ini adalah merupakan sarana untuk mengembangkan dan mengimplementasikan  teori dan ilmu pengetahuan yang didapatkan dalam mata kuliah Aplikasi Jaringan Komputer I di STMIK Widya Utama Purwokerto.

BAB II


A.    Tinjauan Pustaka

Load balance pada mikrotik adalah teknik untuk mendistribusikan beban trafik pada dua atau lebih jalur koneksi secara seimbang, agar trafik dapat berjalan optimal, memaksimalkan throughput, memperkecil waktu tanggap dan menghindari overload pada salah satu jalur koneksi. Selama ini banyak dari kita yang beranggapan salah, bahwa dengan menggunakan loadbalance dua jalur koneksi , maka besar bandwidth yang akan kita dapatkan menjadi dua kali lipat dari bandwidth sebelum menggunakan loadbalance (akumulasi dari kedua bandwidth tersebut). Hal ini perlu kita perjelas dahulu, bahwa loadbalance tidak akan menambah besar bandwidth yang kita peroleh, tetapi hanya bertugas untuk membagi trafik dari kedua bandwidth tersebut agar dapat terpakai secara seimbang. 
Load balance pada mikrotik adalah teknik untuk mendistribusikan beban trafik pada dua atau lebih jalur koneksi secara seimbang, agar trafik dapat berjalan optimal, memaksimalkan throughput, memperkecil waktu tanggap dan menghindari overload pada salah satu jalur koneksi.
Selama ini banyak dari kita yang beranggapan salah, bahwa dengan menggunakan loadbalance dua jalur koneksi , maka besar bandwidth yang akan kita dapatkan menjadi dua kali lipat dari bandwidth sebelum menggunakan loadbalance (akumulasi dari kedua bandwidth tersebut). Hal ini perlu kita perjelas dahulu, bahwa loadbalance tidak akan menambah besar bandwidth yang kita peroleh, tetapi hanya bertugas untuk membagi trafik dari kedua bandwidth tersebut agar dapat terpakai secara seimbang . (ferdi, 2010)

BAB III

A.    Pengertian Load Balancing

Load Balancing adalah sebuah konsep yang gunanya untuk menyeimbangkan beban atau muatan pada infrastruktur Teknologi Informasi sebuah perusahaan/ instansi. Agar seluruh departemen/ bagian dapat memanfaatkan secara maksimal dan optimal yang berfungsi menggabungkan beberapa line Internet Service Provider. Jaringan sangat penting bila skala dalam jaringan komputer makin besar demikian juga traffic data yang ada dalam jaringan komputer makin lama makin tinggi.  Load balancing atau penyeimbangan beban dalam jaringan sangat penting bila skala dalam jaringan komputer makin besar demikian juga traffic data yang ada dalam jaringan komputer makin lama makin tinggi.
Layanan Load Balancing memungkinkan pengaksesan sumber daya dalam jaringan didistribusikan ke beberapa host lainnya agar tidak terpusat sehingga unjuk kerja jaringan komputer secara keseluruhan bisa stabil. Ketika sebuah sebuah server sedang diakses oleh para pengguna, maka sebenarnya server tersebut sebenarnya sedang terbebani karena harus melakukan proses permintaan kepada para penggunanya. Jika penggunanya banyak maka prosesnyapun banyak. Session-session komunikasi dibuka oleh server tersebut untuk memungkinkan para pengguna menerima servis dari server tersebut. Jika satu server saja terbebani, tentu server tersebut tidak bisa banyak melayani para penggunanya karena kemampuan melakukan processing ada batasnya. Solusi yang paling ideal adalah dengan  membagi-bagi beban yang datang ke beberapa server. Jadi yang melayani pengguna tidak hanya terpusat pada satu perangkat saja. Teknik ini disebut Teknik Load Balancing.



Adapun manfaat dari Load Balancing :
a.       Menjamin Reliabilitias layanan berarti kepercayaan terhadap sebuah sistem untuk dapat terus melayani pengguna dengan sebaik-baiknya. Jaminan realibilitas memungkinkan pengguna dapat melakukan pekerjaan sebaik-baiknya dengan lancar melalui layanan tersebut.
b.      Skalabilitas dan ketersediaan Jika dalam sebuah jaringan komputer jika hanya terdapat satu buah server mempunyai pengertian terdapat satu titik masalah. Seandainya tiba-tiba server itu mati maka layanan terhadap pengguna akan terganggu. Dengan melakukan penambahan server dan membentuk server farm maka skalabilitas akan meningkat dan selain itu faktor ketersediaan juga akan meningkat.

B.     Metode Load Balancing

Berikut metode-metode dalam Load Balancing :
a.       Load`Balancing dengan Hardware / Switch
Sistem Load Balancing jenis ini diciptakan dengan menggunakan bantuan sebuah chip khusus yang sering disebut ASICS. ASICS berwujud sebuah microprocessor  khusus yang hanya memproses algoritma dan perhitungan spesifik sehingga performa Load Balancing cukup handal karena hanya perhitungan dan logika Load Balancing saja yang dioptimasi didalamnya. Load Balancing jenis ini umumnya berwujud sebuah switch. Kelemahannya karena interfacenya yang kurang user friendly dan tingkat fleksibilitas perangkat juga rendah karena sebagian besar inteligennya sudah tertanam didalam hardware.
b.  Load`Balancing dengan Software
Keuntungan yang paling menonjol menggunakan metode ini adalah : tingkat kemudahan pemakaian yang lebih user friendly. Keuntungan lain jika ada penambahan fitur atau fasilitas tambahan tidak perlu mengganti keseluruhan perangkat load balancing. Performa proses load balancing dipengaruhi oleh prangkat komputer yang digunakan, tidak bisa hanya mengandalkan kemampuan software yang canggih saja. Perangkat keras yang dapat mempengaruhi performa metode ini adalah kartu jaringan yang digunakan, besarnya RAM pada perangkat, media penyimpanan yang besar dan cepat, dsb. Sehingga performa metode ini sulit untuk bisa diperkirakan.
b.       Load Balancing dengan perangkat perpaduan Hardware dan Software
Hardware yang dioptimasi dan diisi dengan platform berbasis Linux atau BSD yang dioptimisasi adalah konfigurasi yang biasanya digunakan untuk menjalankan software utama load balancing. Fleksibilitas yang luar biasa didapatkan mulai dari menggunakan hardware yang selalu up to date sampai dengan menggunakan operating system dengan patch terbaru. Sehingga waktu guna dari perangkat ini dapat lebih panjang daripada sebuah switch khusus yang tidak fleksibel. Solusi ini tentunya jauh lebih murah dibandingkan dengan solusi hardware khusus atau solui software saja.

C.    Algoritma dalam Load Balancing

Berikut algoritma dalam load balancing :
a)      Round Robin and Random Algorithms
Pada algoritma Round Robin and Random proses dibagi secara merata antara semua prosesor. Setiap proses baru yang ditugaskan untuk prosesor baru untuk putaran robin. Urutan proses alokasi dipertahankan pada setiap prosesor lokal independen dari alokasi dari prosesor. Dengan algoritma round robin sama beban kerja diharapkan untuk bekerja dengan baik. Round Robin dan skema Acak  bekerja dengan baik dengan jumlah proses lebih besar dari jumlah prosesor .

Keuntungan dari algoritma Round Robin adalah bahwa hal itu tidak memerlukan komunikasi antarproses. Round Robin dan algoritma Acak keduanya bisa mencapai kinerja terbaik di antara semua algoritma load balancing untuk aplikasi tertentu tujuan khusus. Dalam Robin Round umum dan Acak tidak diharapkan untuk  mencapai kinerja yang baik dalam kasus umum.
b)       Algorithm Middle Manager
Dalam algoritma ini , prosesor pusat memilih host untuk proses baru. Prosesor minimal dimuat tergantung pada beban keseluruhan yang dipilih ketika proses dibuat. Load manajer memilih host untuk proses baru sehingga beban prosesor menegaskan ke tingkat yang sama sebanyak mungkin. Dari informasi tangan di manajer sistem pembebanan beban negara pusat membuat load balancing penghakiman. Informasi ini diperbarui oleh prosesor remote, yang mengirim pesan setiap kali beban pada mereka perubahan. Informasi ini dapat bergantung pada menunggu proses induk penyelesaian proses anak-anaknya, akhir eksekusi paralel Manajer load load balancing membuat keputusan berdasarkan informasi beban sistem, sehingga keputusan terbaik ketika proses dibuat. Tingginya tingkat komunikasi antar-proses yang bisa membuat negara bottleneck. Algoritma ini diharapkan untuk melakukan lebih baik daripada aplikasi paralel, terutama bila kegiatan dinamis diciptakan oleh
host yang berbeda.
c)      Threshold Algorithm
Menurut algoritma ini, proses ditugaskan segera setelah penciptaan ke host. Host untuk proses baru dipilih secara lokal tanpa mengirim pesan jarak jauh. Setiap prosesor menyimpan salinan pribadi dari beban sistem. Beban prosesor bisa mencirikan oleh salah satu dari tiga tingkatan: underloaded, medium dan Overloaded. Dua parameter ambang tunder dan Tupper dapat digunakan untuk menggambarkan level.

Pada awalnya, semua prosesor dianggap berada di bawah dimuat. Ketika keadaan beban prosesor melebihi batas tingkat beban, maka mengirimkan pesan tentang negara beban baru untuk semua prosesor terpencil, secara teratur memperbarui mereka untuk keadaan beban aktual dari seluruh sistem. Jika negara lokal tidak kelebihan beban maka proses dialokasikan secara lokal. Jika tidak, remote di bawah prosesor dimuat dipilih, dan jika tidak ada tuan rumah tersebut terjadi, prosesnya juga dialokasikan secara lokal. Algoritma Ambang batas memiliki proses komunikasi yang rendah antar dan sejumlah besar alokasi proses lokal. Kemudian menurunkan alokasi overhead proses remote dan overhead dari pengaksesan memori jauh, yang menyebabkan peningkatan kinerja.

Kelemahan dari algoritma ini adalah bahwa semua proses dialokasikan secara lokal ketika semua prosesor terpencil kelebihan beban. Sebuah beban pada satu prosesor kelebihan beban bisa jauh lebih tinggi dari pada prosesor kelebihan beban lain, menyebabkan gangguan signifikan dalam load balancing, dan meningkatkan waktu eksekusi sebuah aplikasi Dinamis
d)     Central Queue Algorithm
Central Queue Algorithm  bekerja pada prinsip distribusi dinamis. Ini pusat kegiatan baru dan permintaan yang tidak terpenuhi sebagai antrian FIFO pada host utama. Setiap aktivitas baru tiba di queue manager dimasukkan ke dalam antrian. Kemudian, setiap kali permintaan untuk kegiatan diterima oleh manajer antrian, ia bisa menghilangkan kegiatan pertama dari antrian dan mengirimkannya ke pemohon. Jika tidak ada kegiatan siap dalam antrian, permintaan buffer, sampai aktivitas baru tersedia. Jika aktivitas baru tiba di queue manager sementara ada terjawab permintaan dalam antrian, permintaan pertama yang akan dihapus dari antrian dan kegiatan baru yang ditugaskan untuk itu.
Ketika beban prosesor berada di bawah ambang batas, manajer beban lokal mengirim permintaan untuk aktivitas baru kepada manajer beban pusat. Manajer beban pusat menjawab permintaan segera jika suatu aktivitas siap ditemukan dalam antrian proses-permintaan, atau antrian permintaan sampai aktivitas baru tiba.
e)      Local Queue Algorithm
Fitur utama dari algoritma ini adalah dukungan proses migrasi dinamis. Ide dasar dari algoritma antrian lokal alokasi statis dari semua proses baru dengan proses migrasi yang diprakarsai oleh tuan rumah pada saat beban yang berada di bawah ambang batas, adalah parameter yang ditetapkan pengguna dari algoritma.
Parameter yang mendefinisikan jumlah minimal proses siap manajer beban upaya untuk memberikan pada setiap prosesor. Awalnya, proses-proses baru yang dibuat pada host utama dialokasikan pada semua host di bawah dimuat. Jumlah kegiatan paralel yang diciptakan oleh paralel pertama membangun pada host utama biasanya cukup untuk alokasi pada semua host remote. Sejak saat itu, semua proses dibuat pada host utama dan semua host lainnya dialokasikan secara lokal.
Ketika tuan rumah yang mendapat di bawah dimuat, manajer beban lokal berusaha untuk mendapatkan beberapa proses dari host remote. Ini secara acak mengirimkan permintaan dengan jumlah proses siap lokal untuk manajer beban terpencil. Ketika seorang manajer beban menerima permintaan seperti itu, hal itu membandingkan nomor lokal proses siap dengan jumlah yang diterima. Jika yang pertama lebih besar dari yang terakhir, maka beberapa proses yang berjalan dipindahkan ke pemohon dan konfirmasi afirmatif dengan jumlah proses yang ditransfer dikembalikan.

Parameter algoritma load balancing
Kinerja algoritma load balancing berbagai diukur dengan parameter berikut :
a)      Overload Rejection
Jika Load Balancing tidak tindakan overload mungkin diperlukan tambahan penolakan. Ketika situasi overload berakhir maka langkah-langkah overload pertama penolakan dihentikan. Setelah periode penjaga singkat Load Balancing juga ditutup.
b)      Fault Toleran
Parameter ini memberikan bahwa algoritma dapat mentolerir kesalahan berliku-liku atau tidak. Hal ini memungkinkan algoritma untuk terus beroperasi dengan benar dalam hal kegagalan beberapa. Jika kinerja menurun algoritma, menurunkan sebanding dengan keseriusan kegagalan, bahkan kegagalan kecil dapat menyebabkan kegagalan total load balancing.
c)      Forecasting Accuracy
Peramalan adalah derajat kesesuaian hasil dihitung ke nilai sebenarnya yang akan dihasilkan setelah eksekusi. Algoritma statis memberikan tingkat akurasi yang lebih dari algoritma yang dinamis seperti dalam asumsi yang paling bekas dibuat selama waktu kompilasi dan di kemudian ini dilakukan selama eksekusi.
d)     Stabilitas
Stabilitas bisa dicirikan dalam hal penundaan dalam transfer informasi antara prosesor dan keuntungan dalam algoritma load balancing dengan mendapatkan performa yang lebih cepat dengan jumlah waktu tertentu.
e)      Sentralisasi atau Desentralisasi
Skema terpusat menyimpan informasi global di node yang ditunjuk. Semua nodepengirim atau penerima mengakses node yang ditunjuk untuk menghitung jumlah beban-transfer dan juga untuk memeriksa bahwa tugas harus dikirim atau diterima dari. Dalamload balancing didistribusikan, setiap node menjalankan keseimbangan secara terpisah.Node menganggur dapat memperoleh beban selama runtime dari antrian global bersama proses.

D.    Load Balancing dalam Windows 2000 Advanced Server

Jika dalam sebuah jaringan komputer sudah terinstall dalam komputer servers sistem operasi Windows 2000 Advanced Server maka tentunya dapat diinstall juga layanan Load Balancing yang dapat membuat sebuah jaringan tersebut dapat diperluas (skalabilitas), dapat diandalkan, dan selalu tersedia untuk melayani pengguna. Dapat diperluas berarti sebuah jaringan dapat menambahkan infrastruktur seperti menambah domain baru, komponen sistem lainnya sesuai dengan kebutuhan.

Dalam penggunaan jaringan komputer tentunya terdapat aplikasi yang mendukung optimalisasi penggunaan jaringan komputer dan salah satunya adalah Aplikasi Kolaborasi yang berjalan dalan jaringan komputer. Aplikasi ini dimaksudkan agar pengguna dapat melakukan kolaborasi dalam pekerjaan melalui penggunaan jaringan komputer dan tentunya didalamnya terdapat layanan pengiriman pesan (email) yang menjadi dasar dalam berkolaborasi. Aplikasi kolaborasi ini biasanya bisa dikembangkan untuk membuat atau mengatur sebuah pekerjaan bisa berjalan lebih efektif dan efisien tanpa harus mempertimbangkan lokasi dari anggota kelompok yang berkolaborasi tersebut. Dari sisi pembebanan penggunaan aplikasi ini cukup menyita sumber daya dalam jaringan komputer seperti bandwidth, memory setiap host dan traffic.

Untuk Operating System menggunakan Windows 2000 Advanced Server Service Pack 2 yang mendukung Load Balancing dan Cluster Service. Sedangkan untuk Application terdiri dari sebagai berikut:
· Microsoft Exchange 2000 ASP
· Internet Information Service
· Microsoft Terminal Service
Dari fitur operating sistem yang digunakan adalah sebagai berikut:
· DNS
· Active Directory
· Load Balancing dan Cluster Service
· Protocol TCP/IP

Khusus protocol TCP/IP, pengalamatan setiap host/client menggunakan alamat statis tidak dinamik dengan pertimbangan jumlah titik jaringan yang terkoneksi masih sedikit. Komputer server khususnya untuk akses jaringan komputer menggunakan network adapter Fast Ethernet dengan speed 100Mbps. Network processor yang digunakan adalah Switch dengan pertimbangan keandalan dan kecepatan akses serta manajemen.

E.     Contoh Konfigurasi Load Balancing

Berikut contoh konfigurasi load balancing :
a)      Konfigurasi Dasar

Berikut ini adalah Topologi Jaringan dan IP address yang akan kita gunakan


Gambar 1

/ip address
add address=192.168.101.2/30 interface=ether1
add address=192.168.102.2/30 interface=ether2
add address=10.10.10.1/24 interface=wlan2
/ip dns
set allow-remote-requests=yes primary-dns=208.67.222.222 secondary-dns=208.67.220.220

Untuk koneksi client, kita menggunakan koneksi wireless pada wlan2 dengan range IP client 10.10.10.2 s/d 10.10.10.254 netmask 255.255.255.0, dimana IP 10.10.10.1 yang dipasangkan pada wlan2 berfungsi sebagai gateway dan dns server dari client. Jika anda menggunakan DNS dari salah satu isp anda, maka akan ada tambahan mangle
.
Setelah pengkonfigurasian IP dan DNS sudah benar, kita harus memasangkan default route ke masing-masing IP gateway ISP kita agar router meneruskan semua trafik yang tidak terhubung padanya ke gateway tersebut. Disini kita menggunakan fitur check-gateway berguna jika salah satu gateway kita putus, maka koneksi akan dibelokkan ke gateway lainnya. 
/ip route
add dst-address=0.0.0.0/0 gateway=192.168.101.1 distance=1 check-gateway=ping
add dst-address=0.0.0.0/0 gateway=192.168.102.1 distance=2 check-gateway=ping

Untuk pengaturan Access Point sehingga PC client dapat terhubung dengan wireless kita, kita menggunakan perintah 
/interface wireless
set wlan2 mode=ap-bridge band=2.4ghz-b/g ssid=Mikrotik disabled=no


Agar pc client dapat melakukan koneksi ke internet, kita juga harus merubah IP privat client ke IP publik yang ada di interface publik kita yaitu ether1 dan ether2. 
/ip firewall nat
add action=masquerade chain=srcnat out-interface=ether1
add action=masquerade chain=srcnat out-interface=ether2

Sampai langkah ini, router dan pc client sudah dapat melakukan koneksi internet. Lakukan ping baik dari router ataupun pc client ke internet. Jika belum berhasil, cek sekali lagi konfigurasi
yang telah dibuat
b)      Webproxy Internal 
Pada routerboard tertentu, seperti RB450G, RB433AH, RB433UAH, RB800 dan RB1100 mempunyai expansion slot (USB, MicroSD, CompactFlash) untuk storage tambahan. Pada contoh berikut, kita akan menggunakan usb flashdisk yang dipasangkan pada slot USB. Untuk pertama kali pemasangan, storage tambahan ini akan terbaca statusnya invalid di /system store. Agar dapat digunakan sebagai media penyimpan cache, maka storage harus diformat dahulu dan diaktifkan Nantinya kita tinggal mengaktifkan webproxy dan set cache-on-disk=yes untuk menggunakan media storage kita. Jangan lupa untuk membelokkan trafik HTTP (tcp port 80) kedalam webproxy kita. 
/store disk format-drive usb1 
/store
add disk=usb1 name=cache-usb type=web-proxy
activate cache-usb

/ip proxy
set cache-on-disk=yes enabled=yes max-cache-size=200000KiB port=8080

/ip firewall nat
add chain=dstnat protocol=tcp dst-port=80 in-interface=wlan2 action=redirect to-ports=8080
c)      Pengaturan Mangle 
Pada loadbalancing kali ini kita akan menggunakan fitur yang disebut PCC (Per Connection Classifier). Dengan PCC kita bisa mengelompokan trafik koneksi yang melalui atau keluar masuk router menjadi beberapa kelompok. Pengelompokan ini bisa dibedakan berdasarkan src-address, dst-address, src-port dan atau dst-port. Router akan mengingat-ingat jalur gateway yang dilewati diawal trafik koneksi, sehingga pada paket-paket selanjutnya yang masih berkaitan dengan koneksi awalnya akan dilewatkan  pada jalur gateway yang sama juga. Kelebihan dari PCC ini yang menjawab banyaknya keluhan sering putusnya koneksi pada teknik loadbalancing lainnya sebelum adanya PCC karena perpindahan gateway.
Sebelum membuat mangle loadbalance, untuk mencegah terjadinya loop routing pada trafik, maka semua trafik client yang menuju network yang terhubung langsung dengan router, harus kita bypass dari loadbalancing. Kita bisa membuat daftar IP yang masih dalam satu network router dan  memasang mangle pertama kali sebagai berikut 
/ip firewall address-list
add address=192.168.101.0/30 list=lokal
add address=192.168.102.0/30 list=lokal
add address=10.10.10.0/24 list=lokal

/ip firewall mangle
add action=accept chain=prerouting dst-address-list=lokal in-interface=wlan2 comment=”trafik lokal”
add action=accept chain=output dst-address-list=lokal

Pada kasus tertentu, trafik pertama bisa berasal dari Internet, seperti penggunaan remote winbox atau telnet dari internet dan sebagainya, oleh karena itu kita juga memerlukan mark-connection untuk menandai trafik tersebut agar trafik baliknya juga bisa melewati interface dimana trafik itu masuk 
/ip firewall mangle
add action=mark-connection chain=prerouting connection-mark=no-mark in-interface=ether1 new-connection-mark=con-from-isp1 passthrough=yes comment=”trafik dari isp1”
add action=mark-connection chain=prerouting connection-mark=no-mark in-interface=ether2 new-connection-mark=con-from-isp2 passthrough=yes comment=”trafik dari isp2”

Umumnya, sebuah ISP akan membatasi akses DNS servernya dari IP yang hanya dikenalnya, jadi jika anda menggunakan DNS dari salah satu ISP anda, anda harus menambahkan mangle agar trafik DNS tersebut melalui gateway ISP yang bersangkutan bukan melalui gateway ISP lainnya. Disini kami berikan mangle DNS ISP1 yang melalui gateway ISP1. Jika anda menggunakan publik DNS independent, seperti opendns, anda tidak memerlukan mangle dibawah ini. 
/ip firewall mangle
add action=mark-connection chain=output comment=dns dst-address=202.65.112.21 dst-port=53 new-connection-mark=dns passthrough=yes protocol=tcp comment=”trafik DNS citra.net.id”
add action=mark-connection chain=output dst-address=202.65.112.21 dst-port=53 new-connection-mark=dns passthrough=yes protocol=udp
add action=mark-routing chain=output connection-mark=dns new-routing-mark=route-to-isp1 passthrough=no

Karena kita menggunakan webproxy pada router, maka trafik yang perlu kita loadbalance ada 2 jenis. Yang pertama adalah trafik dari client menuju internet (non HTTP), dan trafik dari webproxy menuju internet. Agar lebih terstruktur dan mudah dalam pembacaannya, kita akan menggunakan custom-chain sebagai berikut : 
/ip firewall mangle
add action=jump chain=prerouting comment=”lompat ke client-lb” connection-mark=no-mark in-interface=wlan2 jump-target=client-lb
add action=jump chain=output comment=”lompat ke lb-proxy” connection-mark=no-mark out-interface=!wlan2 jump-target=lb-proxy

Pada mangle diatas, untuk trafik loadbalance client pastikan parameter in-interface adalah interface yang terhubung dengan client, dan untuk trafik loadbalance webproxy, kita menggunakan chain output dengan parameter out-interface yang bukan terhubung ke interface client. Setelah custom chain untuk loadbalancing dibuat, kita bisa membuat mangle di custom chain tersebut sebagai berikut 
/ip firewall mangle
add action=mark-connection chain=client-lb dst-address-type=!local new-connection-mark=to-isp1 passthrough=yes per-connection-classifier=both-addresses:3/0 comment=”awal loadbalancing klien”
add action=mark-connection chain=client-lb dst-address-type=!local new-connection-mark=to-isp1 passthrough=yes per-connection-classifier=both-addresses:3/1
add action=mark-connection chain=client-lb dst-address-type=!local new-connection-mark=to-isp2 passthrough=yes per-connection-classifier=both-addresses:3/2
add action=return chain=client-lb comment=”akhir dari loadbalancing”

/ip firewall mangle
add action=mark-connection chain=lb-proxy dst-address-type=!local new-connection-mark=con-from-isp1 passthrough=yes per-connection-classifier=both-addresses:3/0 comment=”awal load balancing proxy”
add action=mark-connection chain=lb-proxy dst-address-type=!local new-connection-mark=con-from-isp1 passthrough=yes per-connection-classifier=both-addresses:3/1
add action=mark-connection chain=lb-proxy dst-address-type=!local new-connection-mark=con-from-isp2 passthrough=yes per-connection-classifier=both-addresses:3/2
add action=return chain=lb-proxy comment=”akhir dari loadbalancing”

Untuk contoh diatas, pada loadbalancing client dan webproxy menggunakan parameter pemisahan trafik pcc yang sama, yaitu both-address, sehingga router akan mengingat-ingat berdasarkan src-address dan dst-address dari sebuah koneksi. Karena trafik ISP kita yang berbeda (512kbps dan 256kbps), kita membagi beban trafiknya menjadi 3 bagian. 2 bagian pertama akan melewati gateway ISP1, dan 1 bagian terakhir akan melewati gateway ISP2. Jika masing-masing trafik dari client dan proxy sudah ditandai, langkah berikutnya kita tinggal membuat mangle mark-route yang akan digunakan dalam proses routing nantinya 
/ip firewall mangle
add action=jump chain=prerouting comment=”marking route client” connection-mark=!no-mark in-interface=wlan2 jump-target=route-client
add action=mark-routing chain=route-client connection-mark=to-isp1 new-routing-mark=route-to-isp1 passthrough=no
add action=mark-routing chain=route-client connection-mark=to-isp2 new-routing-mark=route-to-isp2 passthrough=no
add action=mark-routing chain=route-client connection-mark=con-from-isp1 new-routing-mark=route-to-isp1 passthrough=no
add action=mark-routing chain=route-client connection-mark=con-from-isp2 new-routing-mark=route-to-isp2 passthrough=no
add action=return chain=route-client disabled=no

/ip firewall mangle
add action=mark-routing chain=output comment=”marking route proxy” connection-mark=con-from-isp1 new-routing-mark=route-to-isp1 out-interface=!wlan2 passthrough=no
add action=mark-routing chain=output connection-mark=con-from-isp2 new-routing-mark=route-to-isp2 out-interface=!wlan2 passthrough=no
d)     Pengaturan Routing 
Pengaturan mangle diatas tidak akan berguna jika anda belum membuat routing berdasar mark-route yang sudah kita buat. Disini kita juga akan membuat routing backup, sehingga apabila sebuah gateway terputus, maka semua koneksi akan melewati gateway yang masing terhubung 
/ip route
add check-gateway=ping dst-address=0.0.0.0/0 gateway=192.168.101.1 routing-mark=route-to-isp1 distance=1
add check-gateway=ping dst-address=0.0.0.0/0 gateway=192.168.102.1 routing-mark=route-to-isp1 distance=2
add check-gateway=ping dst-address=0.0.0.0/0 gateway=192.168.102.1 routing-mark=route-to-isp2 distance=1
add check-gateway=ping dst-address=0.0.0.0/0 gateway=192.168.101.1 routing-mark=route-to-isp2 distance=2
e)      Pengujian 
Dari hasil pengujian, didapatkan hasil sebagai berikut :


Gambar 2

Dari gambar terlihat, bahwa hanya dengan melakukan 1 file download (1 koneksi), kita hanya mendapatkan speed 56kBps (448kbps) karena pada saat itu melewati gateway ISP1, sedangkan jika kita mendownload file (membuka koneksi baru) lagi pada web lain, akan mendapatkan 30kBps (240kbps). Dari pengujian ini terlihat dapat disimpulkan bahwa 
512kbps + 256kbps ≠ 768kbps 
Loadbalancing menggunakan teknik pcc ini akan berjalan efektif dan mendekati seimbang jika semakin banyak koneksi (dari client) yang terjadi. Gunakan ISP yang memiliki bandwith FIX bukan Share untuk mendapatkan hasil yang lebih optimal. Load Balance menggunakan PCC ini bukan selamanya dan sepenuhnya sebuah solusi yang pasti berhasil baik di semua jenis network, karena proses penyeimbangan dari traffic adalah berdasarkan logika probabilitas.  


BAB IV

KESIMPULAN


1.    Load balancing atau penyeimbangan beban dalam jaringan sangat penting bila skala dalam jaringan komputer makin besar demikian juga traffic data yang ada dalam jaringan komputer makin lama makin tinggi.
2.    Layanan Load Balancing dimungkinkan pengaksesan sumber daya dalam jaringan didistribusikan ke beberapa host lainnya agar tidak terpusat sehingga unjuk kerja jaringan komputer secara keseluruhan bisa stabil.
3.    Dengan menggunakan metode load balancing maka merupakan solusi yang tepat dan efektif untuk menangani beban server yang sibuk.
4.    Dengan menggunakan metode load balancing maka jalannya sebuah aplikasi lebih terjamin dalam melayani para pengguna aplikasi.




Ferdi Risky, Mei 2010, Konsep Load Balancing dan Manfaatnya, http://ferdisky.blogspot.com/2010/05/konsep-load-balancing-dan-manfaatnya.html, diakses 11 Juni 2012.
Pujo Dewobroto, 2012, Load Balance menggunakan Metode PCC,
http://www.mikrotik.co.id/artikel_lihat.php?id=34 diakses 11 Juni 2012
Allan Leinword & Karen Fang Conroy, Netwok Management, A Practical Persepective, Addison Wesley, New York, 1996.
Andrew S. Tanenbaum, Computer Network, 3rd Edition, Prentice Hall, New Jersey, 1996.
Drew Heywood, Konsep dan Penerapan Microsoft TCP/IP, Andi Offset, Yogyakarta, 1999.
William Stalling, Komunikasi Data dan Komputer: Jaringan Komputer, Salemba Teknika, Jakarta, 2000.

Baca Selanjutnya »